[fixed] Access Violation in MYINFOCORE.DLL

Discuss MyInfo and get help here
Post Reply
SleepyBalrog
Posts: 24
Joined: Sat Aug 09, 2014 6:24 pm

[fixed] Access Violation in MYINFOCORE.DLL

Post by SleepyBalrog »

I frequently get an access violation error in MYINFOCORE.DLL, it seem to occur:
- when switching note (sometimes)
- autosaving changes in a note (sometimes)
- closing a notebook (most times)
- Exiting the application (most times, the error dialog also prevent windows from shutting down and this result in many such dialog windows (1 every 4-5 secoonds, so it can be 20-30 or more if you try to address it instead of choosing shut down anyway).

I usually have 2 or more notebooks open, sometimes 4 or 5, most of them small but one is about 18MB and another at 400+ MB (with lots of images embedded in the notes). The bug seem to happen more often when one or both of these notebooks are open, but may also happen when only the smaller 2-3 MB notebooks are open.

Image
SleepyBalrog
Posts: 24
Joined: Sat Aug 09, 2014 6:24 pm

Post by SleepyBalrog »

The last update seems to have made this problem worse, I now seem to always get the error when opening or closing a notebook, or exiting the application / shutting down the computer.

When I get it the error reporting always fail when it pop up which seem to be after acknowledging the problem one or more times (depend on how many errors in a row, or in a session) since the error form only pop up when I try to exit, and the application always restart afterwards which is annoying when you try to exit or shut down the computer. But when immediately trying to close it after a restart I never get an error, nor do it happen when I exit shortly after starting the application.

So it seems to happen more oftern the longer the application is running and the larger the notebooks are (although it still happen when I have two 1-2 MB notebooks open, but then after several hours.

I will send the error report in email, it turned out that the reason I could not paste it into an email was that my email client cleared the clipboard when I started it, since I tried to use gmail in the browser once too, it probably do the same (sometimes this privacy issue make things harder), but notepad++ do not clear the clipboard.
Petko
MyInfo Support
Posts: 2939
Joined: Sun Jul 25, 2004 4:33 pm
Contact:

Post by Petko »

Can you send me a copy of one of the notebooks, which are open when you get the problem most of the times at support@milenix.com?
Petko
MyInfo Support
Posts: 2939
Joined: Sun Jul 25, 2004 4:33 pm
Contact:

Post by Petko »

Fixed in MyInfo 7.0.7 (build 6582).
Post Reply