High background CPU usage [7.0.6]

Discuss MyInfo and get help here
Post Reply
bumblebee
Posts: 2
Joined: Thu Apr 16, 2020 3:04 pm

High background CPU usage [7.0.6]

Post by bumblebee » Thu Apr 16, 2020 3:24 pm

MyInfo 7 uses on average 5% of my CPU while minimized and idle!!?

I suppose it could be building search indices, but my notebook data has been relatively static for a long time. Perhaps it is the new design that constantly detects and save changes, but why is this necessary in a minimized window?

Some mechanism needs to be implemented that suspends whatever is burning CPU cycles for no purpose.

Thanks.

Petko
MyInfo Support
Posts: 2631
Joined: Sun Jul 25, 2004 4:33 pm
Contact:

Post by Petko » Thu Apr 16, 2020 7:38 pm

MyInfo does very few things in the background, so this is strange. Did you experience this for the first time in 7.0.6?

Telesto
Posts: 1213
Joined: Fri Dec 15, 2017 5:32 pm

Post by Telesto » Thu Apr 16, 2020 8:05 pm

CPU usage with MyInfo send to tray bar is fine (great even; 0,16% or something like that). It's 'a bit' CPU consuming minimized at task bar (3%) [7.0.6]. MyInfo 7.0.3 is slightly better (2%). However with a different database open; not sure if that makes the difference.

Telesto
Posts: 1213
Joined: Fri Dec 15, 2017 5:32 pm

Post by Telesto » Fri Apr 17, 2020 4:30 pm

Minimizing MyInfo to the taskbar with the about Window open improves the situation (0,30%)

bumblebee
Posts: 2
Joined: Thu Apr 16, 2020 3:04 pm

Post by bumblebee » Fri Apr 17, 2020 6:38 pm

My PC is older which would explain 5% vs. 3%.

I can confirm that opening "About" or "Options" windows drops CPU cycles. My guess is that some polling loop is running when the main window has focus or is minimized.

Petko
MyInfo Support
Posts: 2631
Joined: Sun Jul 25, 2004 4:33 pm
Contact:

Post by Petko » Sat Apr 18, 2020 11:50 am

Yes, there are some things that MyInfo does in the background. I will try to optimize them further, if possible.

Post Reply