[fixed] Lagging Scroll Functionality

Discuss MyInfo and get help here
Post Reply
Eddie T
Posts: 25
Joined: Mon Dec 30, 2013 2:43 pm

[fixed] Lagging Scroll Functionality

Post by Eddie T » Wed Jul 01, 2020 3:13 pm

Does anyone else have a lag when scrolling through the file tree? I'm running 7.0.6 on a Windows 10 machine with 16gigs of RAM. I've restarted, opened only MyInfo and same thing. I'm not seeing this with any other programs on my machine. Notes scroll perfectly. It's just the tree.

Telesto
Posts: 1228
Joined: Fri Dec 15, 2017 5:32 pm

Post by Telesto » Thu Jul 02, 2020 8:37 am

Some more information would help to identify the issue. Is it a large section (many notes/ count) and are multiple columns/attributes active or not.

It can be slowish under certain conditions for sure

Eddie T
Posts: 25
Joined: Mon Dec 30, 2013 2:43 pm

Post by Eddie T » Thu Jul 02, 2020 4:12 pm

I have 171 notes in it with only the Title displaying.

Inside the editing pane, the note scrolls as expected. In the tree, it has a "choppy" scroll. I don't know how to explain it better. I'm not sitting in my chair twiddling my thumbs as it lags. It isn't that bad. But it is very noticeable. If I grab the slider bar, it slides the tree up and down as you would expect.

Telesto
Posts: 1228
Joined: Fri Dec 15, 2017 5:32 pm

Post by Telesto » Fri Jul 03, 2020 9:41 am

I'm not able to access.. It slow for me, but running Windows 8. Which has a slow scroll flaw anyhow. Not noticing any lag. Except if enabling multiple (2/3) tree attributes.. (which shouldn't happen either there could be a relation)..

Let's wait for Petko

Petko
MyInfo Support
Posts: 2651
Joined: Sun Jul 25, 2004 4:33 pm
Contact:

Post by Petko » Thu Jul 09, 2020 9:57 am

Does it happen only the first time you scroll through some notes, or even the subsequent scrolls through the same notes too?

Eddie T
Posts: 25
Joined: Mon Dec 30, 2013 2:43 pm

Post by Eddie T » Mon Jul 13, 2020 2:50 pm

Subsequent both. I've toggled tags on and off hoping it might cause the RAM to refresh for some reason. Started and restarted my machine several times (I'm good about this because I take my computer to and from work and always shutdown, not sleep).

And to be clear again, in the note itself, scrolling is just like you would expect. It's only in the tree that this behavior is occuring.

Petko
MyInfo Support
Posts: 2651
Joined: Sun Jul 25, 2004 4:33 pm
Contact:

Post by Petko » Tue Aug 04, 2020 9:54 pm

I've done some work in the scrolling area and it should be much faster in the upcoming MyInfo 7.0.7.

Eddie T
Posts: 25
Joined: Mon Dec 30, 2013 2:43 pm

Post by Eddie T » Tue Aug 04, 2020 10:25 pm

Excellent. Could it be because the source files were MyInfo 6 files originally? Maybe I didn't import them correctly?

Petko
MyInfo Support
Posts: 2651
Joined: Sun Jul 25, 2004 4:33 pm
Contact:

Post by Petko » Wed Aug 05, 2020 2:38 pm

No, it has nothing to do with the content of the notebook. The code that draws the items in the tree was not optimized, which caused the lag.

It should be much smoother in MyInfo 7.0.7.

P.S.: There is still some lag when you scroll for the first time through notes, because they are loaded on demand and not when you initially open the file. However, once loaded, scrolling should be a breeze.

Telesto
Posts: 1228
Joined: Fri Dec 15, 2017 5:32 pm

Post by Telesto » Thu Aug 06, 2020 8:11 am

Nice improvement :D

Post Reply